German

Nested
Input file is not in RIFF format
User: paule32
Date: 11/10/2016 7:34 am
Views: 7759
Rating: 0

Hallo,
Ich habe wav 16kHz Sprachdaten angelegt und nach mfc konvertiert mit HCopy.
Hun erhalte ich folgendes ....
wie kann das gelöst werden?

HCompV -A -D -T 1 -C conf -f 0.01 -m -S de.scp -M hmm0 proto

HTK Configuration Parameters[10]
  Module/Tool     Parameter                  Value
#                 TARGETRATE         100000.000000
#                 WINDOWSIZE         250000.000000
#                 TARGETKIND          MFCC_0_D_N_Z
#                 OUTSILWARN                  TRUE
#                 MEASURESIL                 FALSE
#                 USESILDET                   TRUE
#                 ENORMALISE                 FALSE
#                 SOURCEFORMAT                 WAV
#                 SOURCEKIND                HAUDIO
#                 SOURCERATE            625.000000

Calculating Fixed Variance
  HMM Prototype: proto
  Segment Label: None
  Num Streams  : 1
  UpdatingMeans: Yes
  Target Direct: hmm0
  ERROR [+6251]  Input file is not in RIFF format
  ERROR [+6213]  OpenWaveInput: Get[format]HeaderInfo failed
  ERROR [+6313]  OpenAsChannel: OpenWaveInput failed
  ERROR [+6316]  OpenBuffer: OpenAsChannel failed
  ERROR [+2050]  LoadFile: Config parameters invalid
 FATAL ERROR - Terminating program HCompV

Re: Input file is not in RIFF format
User: nsh
Date: 11/10/2016 8:47 am
Views: 1
Rating: 0

Ok, sorry I misunderstood your question, here are few things about your database:

1) Your input audio files are 8 bit. This is supported, but not very good for accuracy. You better record 16khz 16bit PCM, not 16khz 8 bit PCM

2) When you start working with HCompv after already extracting mfc files you need to work with MFC files, you need to create a new config and new scp. Config should include only MFC configuration:

TARGETKIND = MFCC_0_D_N_Z

TARGETRATE = 100000.0

SAVECOMPRESSED = T

SAVEWITHCRC = T

WINDOWSIZE = 250000.0

USEHAMMING = T

PREEMCOEF = 0.97

NUMCHANS = 26

CEPLIFTER = 22

NUMCEPS = 12 

This is not the config used for HCopy, HCopy config is for HCopy only.
You also need to create a new scp which lists only mfc files

./de/mfc/a.mfc

./de/mfc/hallo.mfc

./de/mfc/i.mfc

./de/mfc/ich.mfc

./de/mfc/l.mfc

This scp is used for HCompV and following steps, it is not the scp used for HCopy.
Please follow the tutorial carefully.
Re: Input file is not in RIFF format
User: paule32
Date: 11/10/2016 9:32 am
Views: 1
Rating: 0

Thanks for your answer,

I running into more errors:

HCompV -A -D -T 1 -C de.hcompv.config -f 0.01 -m -S de.hcompv.scp -M hmm0 proto

HTK Configuration Parameters[10]
  Module/Tool     Parameter                  Value
#                 NUMCEPS                       12
#                 CEPLIFTER                     22
#                 NUMCHANS                      26
#                 PREEMCOEF               0.970000
#                 USEHAMMING                  TRUE
#                 WINDOWSIZE         250000.000000
#                 SAVEWITHCRC                 TRUE
#                 SAVECOMPRESSED              TRUE
#                 TARGETRATE         100000.000000
#                 TARGETKIND          MFCC_0_D_N_Z

Calculating Fixed Variance
  HMM Prototype: proto
  Segment Label: None
  Num Streams  : 1
  UpdatingMeans: Yes
  Target Direct: hmm0
  ERROR [+2050]  CheckData: Parameterisation in ./de/mfc/a.mfc is incompatible with hmm proto
 FATAL ERROR - Terminating program HCompV

Re: Input file is not in RIFF format
User: nsh
Date: 11/10/2016 9:48 am
Views: 1
Rating: 0

Your mfccs were extracted with MFCC_0_D_N_Z and config uses MFCC_0_D_N_Z while proto uses MFCC_0_D_A. If you are going to strictly follow the tutorial you need to use MFCC_0_D_A everywhere. If you still want to configure MFCC_0_D_N_Z you need to update proto for MFCC_0_D_N_Z, for example, vector size would be 39.

 

Re: Input file is not in RIFF format
User: paule32
Date: 11/10/2016 10:20 am
Views: 2
Rating: 0

Thank You very much nsh!!!
You clearifying helps me to build the hmm0/proto , and hmm0/vFloors.
In hmm0/proto ... ther is a typo?  -> see:

~o
<STREAMINFO> 1 25
<VECSIZE> 25<NULLD><MFCC_D_N_Z_0><DIAGC>

Now, there is MFCC_D_N_Z_0 ???
Should it not be MFCC_0_D_N_Z ???

Re: Input file is not in RIFF format
User: nsh
Date: 11/10/2016 10:33 am
Views: 3
Rating: 0

I think it's fine if you using it everywhere consistently and there are no errors.

 

Re: Input file is not in RIFF format
User: paule32
Date: 11/10/2016 11:45 am
Views: 2715
Rating: 0

yes, you are right.

What next?
I get:

HRest -A -D -T 1 -C de.hcompv.config -S de.hcompv.scp -M hmm1 -H hmm0/hmmdefs -H hmm0/vFloors

HTK Configuration Parameters[10]
  Module/Tool     Parameter                  Value
#                 NUMCEPS                       12
#                 CEPLIFTER                     22
#                 NUMCHANS                      26
#                 PREEMCOEF               0.970000
#                 USEHAMMING                  TRUE
#                 WINDOWSIZE         250000.000000
#                 SAVEWITHCRC                 TRUE
#                 SAVECOMPRESSED              TRUE
#                 TARGETRATE         100000.000000
#                 TARGETKIND          MFCC_0_D_N_Z

HMM Def Error: GetToken: Symbol expected at line 1/col 2/char 1 in ./de/mfc/a.mfc
  ERROR [+7050]  HMError:
HMM Def Error: LoadHMMSet: GetToken failed at line 1/col 0/char -1 in ./de/mfc/a.mfc
  ERROR [+7050]  HMError:
  ERROR [+2128]  Initialise1: LoadHMMSet failed
 FATAL ERROR - Terminating program HRest

PreviousNext