Speech Recognition Engines

Nested
Sphinx3-07 mysterious error
User: royerfa
Date: 3/10/2008 11:47 am
Views: 5573
Rating: 18

Hello,

 

I am trying sphinx3-07. I installed sphinxbase et sphinx3 sucessfully.

My proble; is that when I run for instance sphinx-simple or others exectuable, I always get the same error.

/usr/local/bin/sphinx3_livedecode: error while loading shared libraries: libs3decoder.so.0: cannot open shared object file: No such file or directory

Meanwhile I know that this library exist, in the file /usr/local/lib

So why didn't he suceed to open it ??

I try with sudo and doesn't change a think.

So I guess this library is at the wrong place what should I do to make it work ? I used the ./configure by default

 

Thx 

--- (Edited on 3/10/2008 11:47 am [GMT-0500] by royerfa) ---

Re: Sphinx3-07 mysterious error
User: nsh
Date: 3/10/2008 12:07 pm
Views: 1879
Rating: 31

Shared library are searched in two main locations. The one is specified in /etc/ld.so.conf file, another is specified by LD_LIBRARY_PATH environment variable. So you have to either edit ld.so.conf and add /usr/local/lib there, then run ldconfig to rebuild cache or export LD_LIBRARY_PATH=/usr/local/lib. See

 http://tldp.org/HOWTO/Program-Library-HOWTO/shared-libraries.html

for more information

 

--- (Edited on 3/10/2008 12:07 pm [GMT-0500] by nsh) ---

PreviousNext