Speech Recognition Engines

problem with HSLab, HTK
User: moughr
Date: 11/13/2010 10:18 am
Views: 7751
Rating: 1

Hi all,

I've installed HTK on cygwin... everything about HTK tools seems to be well done although there was some warnings while config.: something like: makefile seems to ignore the  --datarootdir setting. if someone could help me understanding what happened it would be so nice.

 Buuut nowww I'm facing another problem: when I type  HSLab noname, the following message appears: MakeXGraf: cannot connect to X server. I don' know if there's something missing  about cygwin install ( but I ve installed some lib X11) .  pleeeeeaaaase heeelp

--- (Edited on 11/13/2010 10:18 am [GMT-0600] by moughr) ---

Re: problem with HSLab, HTK
User: kmaclean
Date: 11/13/2010 12:05 pm
Views: 386
Rating: 2

>when I type  HSLab noname, the following message

>appears: MakeXGraf: cannot connect to X server. 

Looks like you might need to install x server - check you Cygwin updater to see if there is a x server package available for download.

HSLab is just HTK's audio recorder - compiling it can be tricky.  

It is usually easier to use something like Audacity


--- (Edited on 11/13/2010 1:05 pm [GMT-0500] by kmaclean) ---

Re: problem with HSLab, HTK
User: moughr
Date: 11/14/2010 12:40 am
Views: 1157
Rating: 1

thanks, that's true, now x sever is well installed, (some applications like xinit run correctly) but there's the same error message. is that in relation with the DISPLAY variable??? how can I solve that? 

--- (Edited on 11/14/2010 7:40 am [GMT+0100] by moughr) ---

Re: problem with HSLab, HTK
User: Layal
Date: 5/9/2013 3:01 pm
Views: 215
Rating: 2

Hi, can i know how you fixed the problem of x server...it keeps giving me the message cannot connect to x server!!!!!!!!

please help....

--- (Edited on 5/9/2013 3:01 pm [GMT-0500] by Visitor) ---

Re: problem with HSLab, HTK
User: Sruti
Date: 6/12/2014 12:40 am
Views: 1676
Rating: 2

Hi all,

I get the following error when i give the command 

C:\htk\bin.win32\HTKDemo>HSLab noname.sig

  ERROR [+6870]  MakeXGraf: Not compiled with X11 support: use HGraf.X.c

 FATAL ERROR - Terminating program HSLab

I have already tried with the following solution

1. Replace the file is HGraf.null.obj  HGraf_WIN32.obj  , HGraf.null.olv replaced HGraf_WIN32.olv;

2 Then recompile HTKLib folder htk_htklib_nt.mkf in cmd command line;

3, Check HTKTools Makefile.in file folder, if you have "-lX11" characters, then delete it, and then recompile the cmd command line HTK Tools folder htk_htktools_nt.mkf file under;

But after the make the changes it gives following error whie recopiling and doesnt recompile. 

cl /nologo /c /ML /W0 /GX /O2 /G5 /Ob2 /D "NDEBUG" /D "WIN32" /D "_WINDO

WS" /I "." /D "WIN32_AUDIO"  /D ARCH=\"WIN32\" /D "PHNALG" HGraf_WIN32.c

NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 10.0\VC\bi

n\cl.EXE"' : return code '0xc0000135'


I will be very gratefull for any solutions to the problem.

Thanks in advance

--- (Edited on 6/12/2014 12:40 am [GMT-0500] by Visitor) ---