Acoustic Model Discussions

Flat
NullPointerException when load n-gram language model
User: Pacer
Date: 7/22/2016 8:59 am
Views: 3139
Rating: 0

Hi,

I managed to train my german 8khz accoustic model with the voxforge-de-20141117 package. It took quite a while to fix all the sentence errors (numbers, signs, missspelling etc.) but finally I got a working model for our telephony purposes. 

We are using a little grammar to filter only the words we want to recognize. All works fine, except when I disable the usage of the grammer to allow Sphinx4 to recognize every word. Then, and only then, I get the following NullPointerExcepttion when loading the LM:

Jul 22, 2016 2:08:18 PM edu.cmu.sphinx.linguist.language.ngram.trie.NgramTrieModel allocate

INFORMATION: Loading n-gram language model from: jar:file:/webapps/qta/WEB-INF/lib/sphinx4-data-5prealpha-20160531.163451-...e_de.lm.bin
java.lang.NullPointerException
at edu.cmu.sphinx.linguist.language.ngram.trie.NgramTrieQuant.setTable(NgramTrieQuant.java:50)
at edu.cmu.sphinx.linguist.language.ngram.trie.BinaryLoader.readQuant(BinaryLoader.java:95)
at edu.cmu.sphinx.linguist.language.ngram.trie.NgramTrieModel.allocate(NgramTrieModel.java:225)
at edu.cmu.sphinx.linguist.lextree.LexTreeLinguist.allocate(LexTreeLinguist.java:334)
at edu.cmu.sphinx.decoder.search.WordPruningBreadthFirstSearchManager.allocate(WordPruningBreadthFirstSearchManager.java:243)
at edu.cmu.sphinx.decoder.AbstractDecoder.allocate(AbstractDecoder.java:103)
at edu.cmu.sphinx.recognizer.Recognizer.allocate(Recognizer.java:164)
at edu.cmu.sphinx.api.StreamSpeechRecognizer.startRecognition(StreamSpeechRecognizer.java:52)
at edu.cmu.sphinx.api.StreamSpeechRecognizer.startRecognition(StreamSpeechRecognizer.java:39)
at com.questico.qta.RTP$2.run(RTP.java:672)
at java.lang.Thread.run(Thread.java:745)

The LM file exists. We tried the LM from within the Voxforge Package (converted it with sphinx_lm_convert to BIN-format). We also generated a new LM using Gooofy (https://github.com/gooofy/voxforge), with the same result.
Does anybody know what we should consider as the reason for this? All other Models work perfectly with AND without grammar (en-us-8khz from CMUSphinx, self-trained Spanish Voxforge model, too.)
Thanks for your help.
Ronny

--- (Edited on 7/22/2016 8:59 am [GMT-0500] by Pacer) ---

PreviousNext