Click here to register.

Speech Recognition Engines

Flat
Re: sphinxtrain error with slave.pl
User: nsh
Date: 3/23/2010 2:49 am
Views: 113
Rating: 3

You don't have dlls in proper place that's why you can't start sphinx3_decode.exe.

 

--- (Edited on 3/23/2010 10:49 [GMT+0300] by nsh) ---

Re: sphinxtrain error with slave.pl
User: Long
Date: 3/23/2010 1:04 pm
Views: 420
Rating: 2

Thanks a lot nsh. I finally got it to run but there are some errors and so i will look into that myself. Thank you for your time.

--- (Edited on 3/23/2010 1:04 pm [GMT-0500] by Visitor) ---

Re: sphinxtrain error with slave.pl
User: bsnayak
Date: 1/22/2014 6:58 am
Views: 1812
Rating: 2

Hallo Nikol abd Jose

I am writting here as the problem with me is very relevant to this question. I have used the latest model of sphinx and tried to run with the an4 database as suggested in tutorial.

At the Module : Decode using models previously trained  I found this error.

Can't open /home/bsnayak/tutorial4/an4/result/an4-1-1.match
word_align.pl failed with error code 65280 at /usr/local/lib/sphinxtrain/scripts/decode/slave.pl line 173.

 

I went to the log directory and checked what is the real problem , it says

SYSTEM_ERROR: "batch.c", line 815: Failed to open control file '/etc/_test.fileids': No such file or directory
Wed Jan 22 04:19:37 2014

I checked the paramteres in my cfg file , all are properly defined, then what is the exact problem here and how i am supposed to solve it.

Do i need to solve it as jose suggested like posted above..

##

editing /etc/ld.so.conf

add a new line with "/usr/local/lib" or the path directory that contains the file "libsphinxbase.so.1"


then run "sudo ldconfig"

##

i couldnt find ld.so.conf. is it still available in the latest model or there is any other way to solve it ??

 Kindly share your suggestions to solve this.

 Thanks a lot

 

 

--- (Edited on 1/22/2014 6:58 am [GMT-0600] by bsnayak) ---

PreviousNext