Click here to register.

General Discussion

Flat
quickstart failure
User: ablackball@hotmail.com
Date: 11/18/2012 9:06 pm
Views: 3972
Rating: 9

I am using ubuntu 12.04. I have tried a couple of methods to get Julius working on this computer and am a bit frustrated.  Resorting to the quickstart download I get this.......

julius-3.5.2-quickstart-linux/julian: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory

It is looking for a library libz.so.1 which does not seem to be part of the package dowloaded with the quickstart tarball.  Please, where do I get this library and where do I put it once it is downloaded.

--- (Edited on 11/18/2012 9:06 pm [GMT-0600] by ablackball@hotmail.com) ---

Re: quickstart failure
User: kmaclean
Date: 11/19/2012 11:56 am
Views: 199
Rating: 10

>libz.so.1: cannot open shared object file:

in Fedora all you need to do is:

yum install libz.so.1

I think apt-get on Ubuntu should allow you to do the same...

Have you tried one of the quickstarts on the nightly build page?

--- (Edited on 11/19/2012 12:56 pm [GMT-0500] by kmaclean) ---

Re: quickstart failure
User: ablackball@hotmail.com
Date: 11/19/2012 8:27 pm
Views: 411
Rating: 9

I tried to use the apt-get command but it cannot find the repository.  I installed the yum command (not typically used with Ubuntu) and it also failed and returned the message "root@*****:/home/*****# yum install libz.so.1
Setting up Install Process
No package libz.so.1 available.
Nothing to do
"

     Tthe ubuntu package installer "synopsis" will install the Julius package (I am still unable to find the libz.so.1 shared library)but will not install all the parameters which will allow me, as a noob, to get started.  It askes for the accoustic models, the grammar files and plenty of other things I do not yet know how to specify.  Indeed, there are dozens of stream output files in my home folder which were likely synthesized by Julius.

     At this point I can either specify a ppa while using apt-get (I have not done this before) or I can use a standard configuration package (I was trying the quickstart for this).

    Is there a standard configuration I can use which will likely work?

 

--- (Edited on 11/19/2012 8:27 pm [GMT-0600] by ablackball@hotmail.com) ---

Re: quickstart failure
User: kmaclean
Date: 11/20/2012 10:34 am
Views: 247
Rating: 11

I think you need the zlib1g package.

(to find this I just googled: "libz.so.1 package name ubuntu" - in case  there are other missing libraries...)

On Fedora, yum will install the correct package if you enter the shared library name...

--- (Edited on 11/20/2012 11:34 am [GMT-0500] by kmaclean) ---

Re: quickstart failure
User: kmaclean
Date: 11/20/2012 11:17 am
Views: 253
Rating: 9

The the quickstarts in the nightly build directory use a newer version of Julius (Julius 4.2):

[   ] Julius-4.2-Quickstart-Linux_AcousticModel-2012-10-22.tgz        22-Oct-2012 04:35  4.2M  

Note: I had to add the 32-bit version of the alsa plugins to get Julius to work:

# yum install alsa-plugins-pulseaudio.i686

then to run julius:

$./julius -input mic -C Sample.jconf

--- (Edited on 11/20/2012 12:17 pm [GMT-0500] by kmaclean) ---

Re: quickstart failure
User: ablackball
Date: 11/20/2012 11:18 am
Views: 1037
Rating: 9

Here is where I am.....

removed all Julius packages and re-installed using synaptic package manager.  It installed the engine and the accoustic models.

 

TYPED IN julius -input mic -C '/home/#######/julius-3.5.2-quickstart-linux/julian.jconf'

Note that I had to point to .jconf file whcih was extracted from the quickstart tarball.

the package started but failed to initialize completely leaving me HERE

------
### read waveform input
Stat: adin_oss: device name = /dev/dsp (application default)
Error: adin_oss: failed to open /dev/dsp
failed to begin input stream

So....?

 

 

--- (Edited on 11/20/2012 11:18 am [GMT-0600] by Visitor) ---

PreviousNext