Click here to register.

General Discussion

Flat
Nothing happens when running JULIUS
User: kiguaran001
Date: 12/19/2016 12:14 pm
Views: 1092
Rating: 0

Hi!

Im trying to run JULIUS life, I have tried it with this command:

~/julius-4.2.2$ julius -C julius.jconf3
STAT: include config: julius.jconf3
~/julius-4.2.2$
 But as you can see nothing is happening, I also tried this command to try to know whats hapening using debug and this is the answer:

~/julius-4.2.2$ julius -debug -C julius.jconf3
STAT: include config: julius.jconf3
DEBUG: args: -dfa sample.dfa -v sample.dict -h PROIEKTUA/AdibideaLinux/modeloak/hmm9/hmmdefs -hlist PROIEKTUA/AdibideaLinux/phones.list1 -smpFreq 16000 -spmodel sp -multipath -gprune safe -iwsppenalty -70.0 -iwsp -penalty1 5.0 -penalty2 20.0 -b2 200 -sb 200.0 -n 1 -lv 4000 -logfile julius.log -quiet

What do you thin about? if someone knows whats happening help please

--- (Edited on 12/19/2016 12:14 pm [GMT-0600] by kiguaran001) ---

Re: Nothing happens when running JULIUS
User: colbec
Date: 12/19/2016 2:02 pm
Views: 17
Rating: 0

You have redirected your logs via "-logfile ..." What is in julius.log? While debugging it might be helpful to turn off "-quiet" to get more information. You can reactivate it when things are working.

--- (Edited on 2016-12-19 3:02 pm [GMT-0500] by colbec) ---

Re: Nothing happens when running JULIUS
User: kiguaran001
Date: 12/20/2016 3:10 am
Views: 28
Rating: 0

I have checked julius.log, and i Have managged to correct the error messages. Now Julius seems to start working, but it asks me to write the mfcc file: (This is what i see)

~/julius-4.2.2$ padsp julius -C julius.jconf3
STAT: include config: julius.jconf3

------
enter MFCC filename->

I have tried enterin the train.list file where there are listed all the mfc files with their path, but it doesnt work, the terminal outputed "killed".

Why is JULIUS asking me for this mfcc filename? and what file have I to put there?

 

--- (Edited on 12/20/2016 3:10 am [GMT-0600] by kiguaran001) ---

Re: Nothing happens when running JULIUS
User: colbec
Date: 12/20/2016 3:32 am
Views: 398
Rating: 0

Bikain, Kepa, gu ia ez.

The prompt for the MFCC filename is the default behaviour when you don't indicate to Julius what audio source you will be using. If you are sure that you need to input MFCC files then that's ok and good luck, you might need to play with "padsp" or leaving that out, it might be superfluous since you have compiled Julius specifically for pulseaudio so it should already be okay without padsp.

If you are trying to input real audio data, you might need to activate one of the -input options, such as "julius -input rawfile -C something.jconf"

--- (Edited on 2016-12-20 4:32 am [GMT-0500] by colbec) ---

PreviousNext