Click here to register.

General Discussion

Flat
Can't run Julius/Julian in Ubuntu Karmic
User: martinrame
Date: 11/24/2009 11:32 am
Views: 7609
Rating: 10

When I execute ./julian -input mic -C julian.jconf it results in this:

include config: julian.jconf
###### check configurations
###### initialize input device
adin_mic_standby: device=/dev/dsp
adin_mic_standby: open device: Device or resource busy
Error: failed to ready input device
Terminated

If I run lspci -vvv, the audio device info is this:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
    Subsystem: Toshiba America Info Systems Device ff1e
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 22
    Region 0: Memory at d6800000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel

 

Any workaround?.

Leonardo.

--- (Edited on 11/24/2009 11:32 am [GMT-0600] by martinrame) ---

Re: Can't run Julius/Julian in Ubuntu Karmic
User: kmaclean
Date: 11/24/2009 12:22 pm
Views: 180
Rating: 8

Hi martinrame,

>adin_mic_standby: open device: Device or resource busy

>Error: failed to ready input device

Can you record anything with arecord or audacity?

Make sure there are no other applications using your microphone or speakers (e.g. browser, Skype, ...). and try Julian again.

Have you tried disabling pulsaudio and then running Julian? 

Ken

--- (Edited on 11/24/2009 1:22 pm [GMT-0500] by kmaclean) ---

Re: Can't run Julius/Julian in Ubuntu Karmic
User: martinrame
Date: 11/24/2009 12:44 pm
Views: 188
Rating: 8

> Can you record anything with arecord or audacity?

Audacity works perfectly.

>Make sure there are no other applications using your microphone or speakers (e.g. browser, Skype, ...). and try Julian again.

No, nothing is open when I try to use julius.

>Have you tried disabling pulsaudio and then running Julian? 

How can I disable it?.


Leonardo.

--- (Edited on 11/24/2009 12:44 pm [GMT-0600] by martinrame) ---

Re: Can't run Julius/Julian in Ubuntu Karmic
User: kmaclean
Date: 11/24/2009 2:38 pm
Views: 128
Rating: 8

>Audacity works perfectly.

what about arecord?

>How can I disable it?.

gnome-system-monitor & then kill the process.

 

--- (Edited on 11/24/2009 3:38 pm [GMT-0500] by kmaclean) ---

Re: Can't run Julius/Julian in Ubuntu Karmic
User: Leonardo
Date: 11/25/2009 6:44 am
Views: 85
Rating: 9

I removed pulseaudio with "sudo apt-get remove pulseaudio" and now julius works!.


Thanks for your help.

Leonardo.

--- (Edited on 11/25/2009 6:44 am [GMT-0600] by Visitor) ---

Re: Can't run Julius/Julian in Ubuntu Karmic
User: kmaclean
Date: 11/25/2009 12:35 pm
Views: 238
Rating: 9

Hi Leonardo,

Removing Pulseaudio might be a bit drastic (other programs in your distro might expect it...), you might try using a newer version of Julius

Note that in Julius version 4 and above, there is no separate Julian version (grammar based recognition)  of Julius... i.e. you use the command line executable "julius" (or something similar) to run your garmmar-based recognition.

Ken

--- (Edited on 11/25/2009 1:35 pm [GMT-0500] by kmaclean) ---

Re: Can't run Julius/Julian in Ubuntu Karmic
User: rbrewer
Date: 3/7/2010 2:17 pm
Views: 960
Rating: 9

you can also try the "pasuspender" command to suspend pulseaudio while running julius.

--- (Edited on 3/7/2010 2:17 pm [GMT-0600] by rbrewer) ---

Re: Can't run Julius/Julian in Ubuntu Karmic
User: Ronie
Date: 7/4/2012 5:22 pm
Views: 300
Rating: 10

"you can also try the "pasuspender" command to suspend pulseaudio while running julius."

 

How?

--- (Edited on 7/4/2012 5:22 pm [GMT-0500] by Visitor) ---

Re: Can't run Julius/Julian in Ubuntu Karmic
User: ablackball@hotmail.com
Date: 11/21/2012 1:03 pm
Views: 332
Rating: 10

Will you please expand on this? I have used the command Julius -input ALSA and it crashes the program

--- (Edited on 11/21/2012 1:03 pm [GMT-0600] by ablackball@hotmail.com) ---

Re: Can't run Julius/Julian in Ubuntu Karmic
User: Bartek
Date: 3/15/2013 12:32 pm
Views: 384
Rating: 3

Try this:

padsp julius -input mic -C Sample.jconf

--- (Edited on 3/15/2013 12:32 pm [GMT-0500] by Visitor) ---

PreviousNext