Click here to register.

Dialog Managers

Nested
Simon/proprietary HTK; Windows binary in English
User: ralfherzog
Date: 6/25/2008 1:39 am
Views: 229
Rating: 13
Hello nsh, you said that "in a long term it doesn't look like a good decision."  Well, what do you propose?  Do you have a better solution?  Maybe use some CMU Sphinx modules (as far as I know, they are released under a free license) instead of the HTK modules (proprietary license)?

I think that the solution that the developers of Simon found is a pretty good one.  But of course, in the long term the proprietary HTK modules should be replaced by modules that are published under a free license (e.g. GPL).  In my opinion, the separate installation of the proprietary HTK modules is a good decision for the moment.

Someone should develop a free replacement for HTK.  So that in the long-term, the HTK modules can be substituted with free modules.

Hello bedahr, one question: My precompiled Windows binary "simon-juliusd-0.1-alpha2.exe" is in the German language.  Is there an English version available?   I don't know how to switch from German to English.

Greetings, Ralf

--- (Edited on 2008-06-25 1:39 am [GMT-0500] by ralfherzog) ---

Re: Simon/proprietary HTK; Windows binary in English
User: Visitor
Date: 6/25/2008 2:44 am
Views: 190
Rating: 13

> So that in the long-term, the HTK modules can be substituted with free modules.

Well that probably would be quite easy if we found a viable replacement for HTK. The only place it is used is the modlemanager so that should be fairly easy to change. 

 

> Hello bedahr, one question: My precompiled Windows binary "simon-juliusd-0.1-alpha2.exe" is in the German language.  Is there an English version available?   I don't know how to switch from German to English.

Hmm sorry to hear that. That is actually untested on windows so far. Under linux this works "out of the box" as we use QLocale to access the systems locale.

 

Is it possible that you use a different locale than en_* (If you don't know what I mean: what language do you speak / is your windows?)? Do you have the file simon_en.qm in your simon/ directory? Do you start simon from this directory?

 

-- bedahr 

--- (Edited on 6/25/2008 2:44 am [GMT-0500] by Visitor) ---

Windows binary not in English so far
User: ralfherzog
Date: 6/25/2008 3:44 am
Views: 179
Rating: 12
Hello bedahr, OK, it has been untested on Windows so far.  I am using Windows XP (English language).  The file "simon_en.qm" is in the simon-directory.  And I started Simon from this directory.

Well, I can live with the German edition for the moment, because my native language is German.  But in my opinion, it would be more attractive for people who are not from a German-speaking country if they could test/evaluate Simon in English under Windows XP.

Maybe this is something for your to do list.

Greetings, Ralf

--- (Edited on 2008-06-25 3:44 am [GMT-0500] by ralfherzog) ---

Re: Windows binary not in English so far
User: Visitor
Date: 6/25/2008 5:04 am
Views: 168
Rating: 15
Of course. That is why we translated simon to English. I will see what goes wrong there as soon as possible. -- bedahr

--- (Edited on 6/25/2008 5:04 am [GMT-0500] by Visitor) ---

Re: Windows binary not in English so far
User: bedahr
Date: 6/25/2008 11:04 am
Views: 182
Rating: 17

Hi again!

 

I tried to reproduce your problem but I only have a german version of XP around. So I set all the regional settings to the US. Still - everything in Windows was in German and the locale (reported by Qt) was "de" (German).

 

So I really have no way to reproduce that problem. That is why I created you a locale-debug version of simon. You can find it here:

http://download.yousendit.com/62B581796960729E

 

It's basically alpha2 but with a popup at start showing you what QLocale reports for your system-locale. Could you please send me what the message states?

 

To keep this thread on-topic you can contact me directly: grasch <ate! simon-listens <doht> org

 

Thank you in advance!

 

-- bedahr 

--- (Edited on 6/25/2008 11:04 am [GMT-0500] by bedahr) ---

modified simon.exe
User: ralfherzog
Date: 6/25/2008 1:52 pm
Views: 206
Rating: 14
Hello bedahr, I downloaded your modified simon.exe program, and replaced the original version in the folder "H:\Program Files\simon\simon-0.1-alpha-2." When I start Simon (double-click on simon.exe), a small windows with the name "soidfj" opens that displays the message text "C." Then I clicked the OK button, and Simon starts in the German language.

When I go to the Windows XP Start Menu - "Control Panel" - "Date, Time, Language and Regional Options"  - "Regional and Language Options", the window "Regional and Language Options"  is opening.  My preferences are set to Germany when it comes to number, currency, time, short date.  And the location is as well set to Germany.  But even if I change these settings to English/United States, Simon starts in German.

I am sorry that I couldn't give you the desired answer.

Greetings, Ralf

--- (Edited on 2008-06-25 1:52 pm [GMT-0500] by ralfherzog) ---

Re: modified simon.exe
User: bedahr
Date: 6/25/2008 2:12 pm
Views: 188
Rating: 15

> I am sorry that I couldn't give you the desired answer.

 But you did! :)

 

Qt reports your locale as "C"-Locale. That is why the translation (set for the "en" locale) didn't get picked up.

 

Is there really a dot after the C?

If so rename your simon_en.qm to simon_C..qm and it should get picked up. (you can restore the original executabe when done)

 

Good luck!

 

-- bedahr 

--- (Edited on 6/25/2008 2:12 pm [GMT-0500] by bedahr) ---

renaming "simon_en.qm" to "simon_C.qm"
User: ralfherzog
Date: 6/25/2008 3:44 pm
Views: 176
Rating: 17
Hello bedahr,

No, there is no dot after the C.  I am just using periods inside quotation marks, which is American style.  But in the future, in such cases I think that it is better to use the British style.  Sorry that I did disturb you.  It won't happen again.  I am just trying to stick to the American language.  But sometimes this can be confusing.

I changed the file name from "simon_en.qm" to "simon_C.qm".  It works!  Simon is now in English.  Thanks for your help.

Greetings, Ralf

--- (Edited on 2008-06-25 3:44 pm [GMT-0500] by ralfherzog) ---

Re: renaming "simon_en.qm" to "simon_C.qm"
User: bedahr
Date: 6/25/2008 4:04 pm
Views: 1219
Rating: 14

Hello again!


> No, there is no dot after the C.  I am just using periods inside quotation marks, which is American style

... Wow. I guess I am just not used to seeing such a thought out detail on the internet (and of course I didn't know that this is an "official" style of quoting) :)

> But in the future, in such cases I think that it is better to use the British style.  Sorry that I did disturb you.

You quoted correctly. I didn't know. Please don't apologize.

I am sorry for not knowing the correct way!


> I changed the file name from "simon_en.qm" to "simon_C.qm".  It works!  Simon is now in English.  Thanks for your help.

Yay! Thanks for testing this! Now I know what to tell the other non-german windows-users when they run into problems...

 

-- bedahr 

--- (Edited on 6/25/2008 4:04 pm [GMT-0500] by bedahr) ---

renaming "simon_en.qm" under Windows Vista
User: ralfherzog
Date: 6/25/2008 10:55 pm
Views: 2325
Rating: 13
Hello, here is something different. I just made a small test.  It is possible to run Simon under Windows Vista Ultimate 64-bit.  And the trick with the locale (renaming the file "simon_en.qm") works under Windows Vista, too.

--- (Edited on 2008-06-25 10:55 pm [GMT-0500] by ralfherzog) ---

PreviousNext